1
{ "placements": [ { "anchor": { "selector": "body", } }, "pos": 4, "type": 1, "style": { "top_m": 5, "bot_m": 10 } } ] }
Home » Tutorial » Komputer

Cara Memblokir Youtube Metode Whitelist dengan Mikrotik

Di lingkungan seperti kantor dan sekolah, seorang administrator jaringan terkadang perlu melakukan pemblokiran akses ke Youtube agar kegiatan lebih produktif pada saat jam kerja.

Perangkat seperti Mikrotik Routerboard dapat melakukan pemblokiran akses, ke website streaming video namun terkadang masih bisa lolos dengan pengaturan metode Layer 7 Protocol.

Metode tersebut kurang bisa diandalkan dikarenakan packet sekarang sudah terenkripsi HTTPS. Sehingga dengan metode Whitelisting dirasa lebih efektif.

Kelemahan metode Layer 7 dalam pemblokiran konten


metode layer 7

Konfigurasi pemblokiran akses ke Youtube dengan metode Layer7 pada router Mikrotik yang umum:

/ip firewall layer7-protocol
add name=youtube regexp="r[0-9]+---[a-z]+-+[a-z0-9-]+\\.googlevideo\\.com"

Dengan metode ini artinya kita memblokir semua packet yang Layer 7 yang direquest user ke URL .googlevideo.com.

Metode ini memiliki kelemahan yaitu, selama browser masih memiliki cookies yang tersimpan pada browser, maka website akan tetap terbuka. Ini dikarenakan browser masih mengingat cache.

Semisalkan pada smartphone yang memiliki paket data internet, ketika switch ke Wifi yang akses youtubenya telah di block Layer 7 maka akan masih tetap terbuka.

Protokol HTTPS bekerja pada OSI Layer7 namun keberadaannya "abu-abu" karena ketika akan handshaking perangkat A dan perangkat B akan terhubung secara terenkripsi, sehingga packet sulit di identifikasi oleh router.

Pemblokiran berbasis content


Dengan metode content, router akan melihat packet yang menuju URL youtube.com lalu menambahkan IP yang berkaitan dengan URL tersebut ke dalam daftar Address List

Tambahkan Mangle


contoh tampilan mangle yang dibuat dengan menggunakan perintah diatas

Pertama-tama mari kita berikan dulu mangle pada router:

/ip firewall mangle add chain=forward src-address=192.168.1.0/24 content=youtube.com action=add-dst-to-address-list address-list=YT-IP comment="Dapatkan IP youtube.com

Catatan : Sesuaikan/ganti IP 192.168.1.0/24 menjadi IP sesuai yang kamu gunakan pada jaringan kamu.

Hasil penambahan Mangle


IP youtube sudah masuk ke address list

Nah, silahkan uji mangle ini dengan membuka URL youtube.com jika settingannya sudah benar maka di Address List akan muncul IP server Youtube, seperti gambar di atas.

 

Tambahkan Filter


contoh tampilan filter yang dibuat menggunakan perintah dibawah

Selanjutnya setelah IP youtube terdaftar di Address List dengan nama YT-IP maka kita tambahkan filter sbb:

/ip firewall filter add chain=forward dst-address-list=YT-IP action=reject reject-with=icmp-network-unreachable comment="Block YT"

Artinya, semua IP yang berasal dari 192.168.1.0/24 yang menuju ke IP youtube.com akan otomatis di reject oleh router

Uji ping ke Youtube


Cara pengujian bisa dilakukan dengan melakukan ping dari komputer ke youtube.com

Sampai disini kamu sudah berhasil memblokir youtube.com. Pengaturan ini berlaku global yaitu mulai dari IP 192.168.1.1 s.d 192.168.1.254.

Namun apabila kamu ingin menambahkan beberapa IP yang tidak terkena settingan ini kamu bisa menerapkan metode whitelisting.

Whitelisting perangkat yang tidak terkena pemblokiran


Konsep whitelisting adalah mengizinkan perangkat atau paket tertentu saja yang boleh melewati router. Ini berkebalikan dengan blacklist yang memblokir akses tanpa melihat perangkat.

Sehingga lebih mudah dikonfigurasi dengan menambahkan Address List tertentu yang tidak terkena pengaturan ini. 

Edit Filter yang dibuat sebelumnya


Gambar diatas, IP di Address list yang bernama "Allow YT" akan diizinkan mengakses youtube.com

Mari kita kembali pada pengaturan sebelumnya (filter), berikan pengaturan tambahan pada Src.Address.List dengan memakai tanda seru (!) seperti ini lalu berikan nama agar mudah di ingat. Saya beri nama "Allow YT"

/ip firewall filter add chain=forward src-address-list=!"Allow YT" dst-address-list=YT-IP action=reject reject-with=icmp-network-unreachable comment="Block YT"

 

Tambahkan Address Listnya


di Address list tekan + lalu masukkan IP yang diizinkan mengakses youtube.com

Selanjutnya kamu bisa menambahkan IP-IP mana saja yang boleh mengakses youtube.com, seperti gambar diatas:

Kelemahan metode Content


Router akan secara otomatis menentukan IP yang digunakan oleh youtube.com. Namun karena youtube adalah salah satu dari layanan Google tentu ada beberapa blok IP yang digunakan secara bersama.

Misalnya adalah Google Play Store. Dengan menambahkan filter content maka platform Play Store tentu akan ikut terblokir juga. Karena didalam Play Store ada video youtube didalamnya.

Hasil pemblokiran Youtube metode Whitelist dengan Mikrotik


youtube.com tidak dapat diakses

Setelah dilakukan seluruh konfigurasi dengan benar, maka hasilnya akan tampak seperti ini, kami sudah melakukan pengujian dan hasilnya sangat memuaskan.

Oke sobat semangkamania, terima kasih sudah membaca tutorial cara memblokir youtube metode whitelist dengan Mikrotik.

Rate Artikel


Komentar Artikel

ARDIANSYAH
08 Sep 2021 | 14:07:25

whitelistnya tidak berfungsi bagaimana ya yang benar

admin@semangkablog
08 Sep 2021 | 22:30:03

Tambahkan IP address di bagian Address List kemudian di beri nama Allow YT, lalu di bagian filter di tambahkan Src Address List Allow YT dan di tambahkan tanda seru. Semoga berhasil ya

Perhatian :
Komentar yang masuk akan dimoderasi terlebih dahulu



Contoh : email_saya@gmail.com



Komentar berhasil di-input
Error!

Artikel Lainnya


Artikel Terbaru


Media Sosial